博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ 1442 Black Box
阅读量:4568 次
发布时间:2019-06-08

本文共 3929 字,大约阅读时间需要 13 分钟。

第k大数维护,我推荐Treap。。谁用谁知道。。。。

                                                          Black Box
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5999   Accepted: 2417

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 
ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 
Let us examine a possible sequence of 11 transactions: 
Example 1 
N Transaction i Black Box contents after transaction Answer 
(elements are arranged by non-descending) 
1 ADD(3) 0 3 
2 GET 1 3 3 
3 ADD(1) 1 1, 3 
4 GET 2 1, 3 3 
5 ADD(-4) 2 -4, 1, 3 
6 ADD(2) 2 -4, 1, 2, 3 
7 ADD(8) 2 -4, 1, 2, 3, 8 
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8 
9 GET 3 -1000, -4, 1, 2, 3, 8 1 
10 GET 4 -1000, -4, 1, 2, 3, 8 2 
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8 
It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 
Let us describe the sequence of transactions by two integer arrays: 
1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 
2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 
The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4

3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3

3
1
2

Source

 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
const int maxNode=444444;
const int INF=0x3f3f3f3f;
int M,N,II,cc;
int arr[33000];
int u[33000];
struct Treap
{
    int root,treapCnt,key[maxNode],priority[maxNode],
    childs[maxNode][2],cnt[maxNode],ssize[maxNode];
    Treap()
    {
        root=0;
        treapCnt=1;
        priority[0]=INF;
        ssize[0]=0;
    }
    void update(int x)
    {
        ssize[x]=ssize[childs[x][0]]+cnt[x]+ssize[childs[x][1]];
    }
    void rotate(int &x,int t)
    {
        int y=childs[x][t];
        childs[x][t]=childs[y][1-t];
        childs[y][1-t]=x;
        update(x);
        update(y);
        x=y;
    }
    void _insert(int &x,int k)
    {
        if(x)
        {
            if(key[x]==k)
            {
                cnt[x]++;
            }
            else
            {
                int t=key[x]<k;
                _insert(childs[x][t],k);
                if(priority[childs[x][t]]<priority[x])
                {
                    rotate(x,t);
                }
            }
        }
        else
        {
            x=treapCnt++;
            key[x]=k;
            cnt[x]=1;
            priority[x]=rand();
            childs[x][0]=childs[x][1]=0;
        }
        update(x);
    }
    int _getKth(int &x,int k)
    {
        if(k<=ssize[childs[x][0]])
        {
            return _getKth(childs[x][0],k);
        }
        k-=ssize[childs[x][0]]+cnt[x];
        if(k<=0)
        {
            return key[x];
        }
        return _getKth(childs[x][1],k);
    }
    void Insert(int k)
    {
        _insert(root,k);
    }
    int GetKth(int k)
    {
        return _getKth(root,k);
    }
}T;
int main()
{
    scanf("%d%d",&M,&N);
    II=0;cc=1;
    for(int i=1;i<=M;i++)
    {
        scanf("%d",arr+i);
    }
    for(int i=1;i<=N;i++)
    {
        scanf("%d",u+i);
    }
    for(int i=1;i<=M;i++)
    {
        T.Insert(arr[i]);
        while(i==u[cc])
        {
            cc++;II++;
            printf("%d\n",T.GetKth(II));
        }
    }
    return 0;
}
* This source code was highlighted by . ( style: Codeblocks )

转载于:https://www.cnblogs.com/CKboss/p/3314032.html

你可能感兴趣的文章
getResource()和getResourceAsStream()以及路径问题
查看>>
00080_泛型
查看>>
Java Map 键值对排序 按key排序和按Value排序
查看>>
[笔面] Java IO和网络编程相关面试
查看>>
Hive默认数据库修改配置
查看>>
[转]基本Guava工具
查看>>
趁着没断网,赶快写总结
查看>>
Eclipse中取消按空格选中自动提示
查看>>
JAVA的Date类与Calendar类比较
查看>>
iOS开发拓展篇—音乐的播放
查看>>
Flink资料(1)-- Flink基础概念(Basic Concept)
查看>>
[BZOJ4012] [HNOI2015]开店
查看>>
iOS5新开发的API总述——WWDC 2011
查看>>
JavaScript 基础——使用js的三种方式,js中的变量,js中的输出语句,js中的运算符;js中的分支结构...
查看>>
基于IdentityServer4的OIDC实现单点登录(SSO)原理简析
查看>>
Multicast Routing
查看>>
java NIO中的buffer和channel
查看>>
使用JRegistry来操作window系统注册表
查看>>
函数递归,算法之二分法,表达式,生成式,匿名函数及常用内置函数
查看>>
Nginx,uWSGI与Django 应用的关系
查看>>